#1 Burning Software

It is currently Sun May 26, 2019 6:24 pm

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: burn blu-ray iso failed by V15.3
PostPosted: Tue Nov 04, 2014 7:25 am 
Offline

Joined: Tue Nov 04, 2014 4:04 am
Posts: 5
I burn a blu-ray iso file to BD-RE disc failed by V15.3, I have no idea where is wrong, and how can I fix it. In log file, I saw some information like this:

11/3 17:39:13.454 (19b8) CStarBurn_CdvdBurnerGrabber::TrackAtOnce(): Method in sequence failed

11/3 17:39:13.464 (19b8) CStarBurn_CdvdBurnerGrabber::TrackAtOnce(): EXITing with failure, status 8, message 'CStarBurn_ScsiTransportSPTI::ExecuteCDB(): Command failed'

11/3 17:39:15.899 (19b8) CStarBurn_CdvdBurnerGrabber::TrackAtOnce(): WARNING! Status 8, message 'CStarBurn_ScsiTransportSPTI::ExecuteCDB(): Command failed'

here is my log file, please help me!


Attachments:
burner_driver.zip [66.22 KiB]
Downloaded 1087 times
Top
 Profile  
 
 Post subject: Re: burn blu-ray iso failed by V15.3
PostPosted: Tue Nov 04, 2014 12:11 pm 
Offline

Joined: Fri Jan 26, 2007 4:31 pm
Posts: 450
Hello,

It's just write error.

A possible cause of the problem:
- Bad media
- Optical drive needs firmware update
- Incompatible media vendor and optical drive (sometimes it happens)

A possible solution of the problem:
- Try another media or another media vendor
- Update firmware


Top
 Profile  
 
 Post subject: Re: burn blu-ray iso failed by V15.3
PostPosted: Wed Nov 05, 2014 2:20 am 
Offline

Joined: Tue Nov 04, 2014 4:04 am
Posts: 5
oh, thanks andrey, I sometimes has the problem, maybe it caused by bad media. I have a puzzle now, how can I know the media is whether good or not ?
If one BD-RE media is formatted failed, does it become a bad media?
Some days ago, I use StarBurn_CdvdBurnerGrabber_BluRayFormat() with profile number 0 to format BD-RE disc, and it always failed, then I use full mode to erase the media, then it can be burned success, but if use fast mode erase, it may be burned failed when blu-ray ISO file bigger than 25G. so I'm not sure the burning failed operation is caused whether by formatting operation failed or not.


Top
 Profile  
 
 Post subject: Re: burn blu-ray iso failed by V15.3
PostPosted: Wed Nov 05, 2014 8:26 am 
Offline

Joined: Tue Nov 04, 2014 4:04 am
Posts: 5
If every time use full mode to erase, it will cost a lot time. So I want to erase discs by full mode for only first time, and later use fast mode or some other modes that will be finish fastly, and make sure my buring can be successful.


Top
 Profile  
 
 Post subject: Re: burn blu-ray iso failed by V15.3
PostPosted: Wed Nov 05, 2014 8:42 am 
Offline

Joined: Thu Dec 22, 2011 8:29 am
Posts: 51
Not all profiles are applicable for disc, we always performs disc formatting during full erasing, but we enumerate all profiles and select a really applicable before call formatting routine. Using inapplicable profiles may cause formatting failure or decreasing read/write speeds.
Also we check disc before write ( formatted or no ) and format it if required.
1. You don't need to call full erase or format before first write.
2. You can use fast erase instead of full before each next writing, be sure your burning will completed successfull :)

Use full erase when you need zerofill confidential information on media only ( to avoid reading and parsing with lowlevel reading tools ), otherwise use fast erase.


Top
 Profile  
 
 Post subject: Re: burn blu-ray iso failed by V15.3
PostPosted: Wed Nov 05, 2014 9:26 am 
Offline

Joined: Tue Nov 04, 2014 4:04 am
Posts: 5
thank you, :P ,but I burn iso failed sometimes, can you give me a demo for burning blu-ray iso file to disc ? Maybe my code has some errors.
I imitated the sdk demo "TrackAtOnceFromFile" project, and burning sometimes is failed. Is it incorrectly ?


Top
 Profile  
 
 Post subject: Re: burn blu-ray iso failed by V15.3
PostPosted: Wed Nov 05, 2014 11:48 am 
Offline

Joined: Tue Nov 04, 2014 4:04 am
Posts: 5
I'm very happ I burn an about 42GB blu-ray iso to BD-RE successful today. The Burning is frozen at 99.9% and still stays more than an hour, so I think it actually is finished and force application stopped. The frozen reason is that the function StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx() doesn't finish. It seems check something all the time.
Here is my log file, I hope you can fix it.


Attachments:
burner_driver.zip [24.84 KiB]
Downloaded 1097 times
Top
 Profile  
 
 Post subject: Re: burn blu-ray iso failed by V15.3
PostPosted: Mon Jan 19, 2015 3:18 pm 
Offline

Joined: Thu Dec 22, 2011 8:29 am
Posts: 51
As i see in last log you use ASPI transport for write. This transport is obsolete, their purpose is backward compatibility with Windows 95/98/Me. We recommend to use SPTI or SPTD transport. Please try and inform us about result.
Regards,
Alex


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group